US Application Degraded Performance
Incident Report for Alchemer
Resolved
This incident has been resolved.
Posted Mar 15, 2021 - 13:40 EDT
Monitoring
A fix has been implemented and we are monitoring the results at this time to ensure platform stability.
Posted Mar 15, 2021 - 12:17 EDT
Identified
Additional app slowness has been identified, a fix is being implemented.
Posted Mar 15, 2021 - 11:24 EDT
Monitoring
A fix has been implemented and we are monitoring to confirm application stability.
Posted Mar 15, 2021 - 11:09 EDT
Investigating
We are currently investigating reports of US application slowness.
Posted Mar 15, 2021 - 10:40 EDT
This incident affected: Alchemer Survey Application (Application - US).