US - Degraded Performance
Incident Report for Alchemer
Resolved
This incident has been resolved.
Posted Mar 01, 2021 - 10:03 EST
Investigating
Users are seeing intermittent errors across their Alchemer Account. Survey taking is not affected and data continues to be collected. We’re aware of the issue and are working on it urgently.

We’re really sorry to be holding you up today! Please know we are working hard to get everything up and running and we will update you here with the latest information.
Posted Mar 01, 2021 - 08:59 EST
This incident affected: Alchemer Survey Application (Application - US) and Reports & Exports (Reports & Exports - US).