US and CA are experiencing intermittent delayed email sending.
Incident Report for Alchemer
Resolved
This incident has been resolved.
Posted Jun 17, 2021 - 18:29 EDT
Update
We are continuing to investigate this issue.
Posted Jun 17, 2021 - 17:14 EDT
Investigating
We are currently investigating this issue.
Posted Jun 17, 2021 - 17:10 EDT
This incident affected: Email Services (Email Service - US, Email Service - CA).