Application accessibility - US
Incident Report for Alchemer
Resolved
This incident has been resolved. Engineering cleared the issue with our domain provider and our application performance was restored.

Thank you for your understanding while we worked on fixing this!
Posted Jul 21, 2021 - 11:35 EDT
Update
Alchemer is experiencing an outage related to an adverse action from our domain provider. We are working diligently to address the issue and will provide regular updates here. Impacts may include access to the application, survey taking or email communication with Alchemer. If you would like to speak to someone, please contact us at 1-800-609-6480.
Posted Jul 21, 2021 - 10:08 EDT
Update
Engineering is still engaged with the domain provider to work towards a solution. We apologize for the inconvenience!
Posted Jul 21, 2021 - 09:29 EDT
Update
Thank you for your patience so far! Our Engineers are still actively engaged with our Domain partner to resolve the issue in the shortest time.
Posted Jul 21, 2021 - 08:29 EDT
Update
We are continuing to work on a fix for the issue together with our Domain partner.
Posted Jul 21, 2021 - 07:25 EDT
Update
The issue has been identified and we are continuing to work with our Domain partner to resolve the issue.
Posted Jul 21, 2021 - 06:04 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 21, 2021 - 05:04 EDT
Identified
The issue has been identified and we are currently working with our Domain partner to resolve the issue.
Posted Jul 21, 2021 - 04:59 EDT
Investigating
Some customers are unable to access Alchemer.com. Survey taking is not affected and data continues to be collected. We’re aware of the issue and are working on it urgently.

We’re really sorry to be holding you up today! Please know we are working hard to get everything up and running and we will update you here with the latest information.
Posted Jul 21, 2021 - 03:17 EDT
This incident affected: Alchemer Survey Application (Application - US) and Survey Taking (Survey Taking - US).