EU Survey Taking Temporarily Unavailable
Incident Report for Alchemer
Resolved
Survey links on the EU service have been returned to standard performance. We are continuing to monitor the situation.
Posted Jun 14, 2021 - 15:08 EDT
Monitoring
Our system administrators have been able to identify the source of the issue and stabilize the issue. Survey links are loading consistently without error message at this time and we are monitoring the situation.
Posted Jun 14, 2021 - 14:15 EDT
Investigating
We are aware of an issue causing survey links on the EU-service to consistently return error messages to respondents upon opening. Our system administrators are working swiftly to resolve the issue. More information to follow.
Posted Jun 14, 2021 - 13:27 EDT
This incident affected: Survey Taking (Survey Taking - EU).