Reports Loading Issue
Incident Report for Alchemer
Resolved
This incident has been resolved.
Posted Dec 23, 2021 - 10:07 EST
Investigating
We continue to see some impact from yesterday's incident caused by the AWS outage. Reports are not loading properly.
Our Engineers are working with AWS to resolve the issue as quickly as possible.
Posted Dec 23, 2021 - 07:25 EST
This incident affected: Reports & Exports (Reports & Exports - US).