Survey Taking Errors for EU Accounts
Incident Report for Alchemer
Resolved
Survey taking and response processing were restored. Engineering continues monitoring our systems to ensure stability.
Posted Jul 05, 2021 - 08:06 EDT
Investigating
Intermittent errors are occurring for respondents taking surveys based on accounts on the EU service. Our engineers are investigating currently to find and fix the source of the problem.

Please click the subscribe button to receive further updates as we work to resolve this issue as soon as possible.
Posted Jul 05, 2021 - 07:15 EDT
This incident affected: Survey Taking (Survey Taking - EU) and Response Processing (Response Processing - EU).