Survey Taking Errors for EU Accounts
Incident Report for Alchemer
Resolved
Engineering identified the root cause and implemented a fix that allows Survey Taking to work as intended.
Response Processing is also catching up and delayed responses should start coming in as soon as the web servers process them.
Posted Jul 01, 2021 - 06:05 EDT
Investigating
Intermittent errors are occurring for respondents taking surveys based on accounts on the EU service. Our Engineers are investigating currently to find and fix the source of the problem.

Please click the subscribe button to receive further updates as we work to resolve this issue as soon as possible!
Posted Jul 01, 2021 - 05:20 EDT
This incident affected: Survey Taking (Survey Taking - EU) and Response Processing (Response Processing - EU).