EU - Degraded Reporting
Incident Report for Alchemer
Resolved
This incident has been resolved.
Posted Mar 15, 2021 - 09:03 EDT
Investigating
We are currently investigating an issue affecting a portion of EU users when viewing reports.
Posted Mar 15, 2021 - 08:21 EDT
This incident affected: Reports & Exports (Reports & Exports - EU).