EU - Degraded Reporting and Exporting
Incident Report for Alchemer
Resolved
This incident has been resolved.
Posted Mar 16, 2021 - 07:36 EDT
Investigating
We are investigating an issue with reports and exports affecting some EU users.
Posted Mar 16, 2021 - 06:37 EDT
This incident affected: Reports & Exports (Reports & Exports - EU).