EU survey taking is currently unavailable.
Incident Report for Alchemer
Resolved
This incident has been resolved.
Posted Jun 12, 2021 - 10:25 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2021 - 10:21 EDT
Investigating
We are currently investigating this issue.
Posted Jun 12, 2021 - 10:16 EDT
This incident affected: Survey Taking (Survey Taking - EU).