EU Application Login Issue
Incident Report for Alchemer
Resolved
This incident has been resolved.
Posted Apr 19, 2021 - 22:34 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 19, 2021 - 21:55 EDT
Identified
We are investigating issues with logging into the EU-based application. Our engineers are working as swiftly as possible to restore normal service. More information to follow.
Posted Apr 19, 2021 - 21:45 EDT
This incident affected: Alchemer Survey Application (Application - EU).