Survey taking affected on EU
Incident Report for Alchemer
Resolved
This incident has been resolved.
Posted Nov 11, 2021 - 10:05 EST
Update
Our Engineers are actively engaged on fixing the root cause in the shortest time. We sincerely apologize for the inconvenience!
Posted Nov 11, 2021 - 09:08 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 11, 2021 - 08:12 EST
Identified
The issue has been identified and we are currently working towards implementing a fix.
Posted Nov 11, 2021 - 06:58 EST
Investigating
We are currently investigating this issue.
Posted Nov 11, 2021 - 06:00 EST
This incident affected: Survey Taking (Survey Taking - EU).